en

“My Custom Styles PRO” is a premium WordPress plugin that gives you the ability to easily and safely add your custom styles (CSS code) to WordPress website’s HEAD section directly out of your WordPress Admin Area, without the need to have an external editor. This is a “PRO” version of the plugin “My Custom Styles”. More features, more power.

Its purpose is to provide a familiar experience to WordPress users. No need for any more editing of the files of your theme and/or plugins for to add custom CSS code. Just add your CSS code in the field on the plugin settings page and this plugin will do the rest for you.

It’s really useful in case of any theme update, because your custom CSS code would never be overwritten. Your custom CSS code will keep on working, no matter how many times you upgrade or switch your theme.

On the plugin settings page you find the CSS editor powered by CodeMirror. It has syntax highlighting and line numbering options. Also this editor supports a tab indentation. If you want more options then tell us and we will be happy to add it.

Features

  • Lightweight and fast
  • Secure code with using clear coding standards
  • Intuitive interface with many settings
  • Cross browser compatible (work smooth in any modern browser)
  • Compatible with all WordPress themes
  • RTL compatible (right to left)
  • Translation ready

Key features include…

  • Ability to temporarily disable all custom snippets
  • Syntax highlighting (by CodeMirror)
  • Line numbering
  • Active line highlighting
  • Editor allow for tab indentation
  • And much, much more!

PRO features include…

  • Unlimited number of fields
  • CSS minifier
  • Automatic backup of all snippets to a file
  • Ability to temporarily disable the certain snippet
  • Ability to collapse/expand the certain fields with code
  • Well documented

Coming soon:

  • Reload the settings page at same position after pushing the save button
  • Multisite network support

Translation

This plugin is ready for translation and has already been translated into several languages.

  • English (default)
  • Russian (translation by Milena Kiseleva)
  • German (translation by Michael)
  • Spanish (translation by Patricio Toledo)

If you want to help translate this plugin then please visit the translation page.

Minimum system requirements:

  • PHP version 5.3 or higher.
  • MySQL version 5.0 or higher.

Recommended system requirements:

  • PHP version 7.0 or higher.
  • MySQL version 5.6 or higher.