“My Syntax Highlighter PRO” is a premium WordPress plugin that gives you the ability to easily and safely embed a syntax-highlighted source code within pages and posts on your WordPress website without losing its formatting. This is a “PRO” version of the plugin “My Syntax Highlighter”. More features, more power.

This plugin supports 154 programming languages, 125 shortcodes and 56 themes. The syntax highlighting feature is implemented using the CodeMirror library.

Syntax highlighting is a feature that displays source code, in different colors and fonts according to the category of terms. Syntax highlighting is one strategy to improve the readability and context of the text; especially for code that spans several pages. The reader can easily ignore large sections of comments or code, depending on what they are looking for.

This plugin also uses standalone Shortcode-Processor to prevent WordPress from converting newlines to HTML paragraphs, replacing apostrophes with typographic quotes and so on.

This plugin is just plug and play, no tedious configurations or hacks, just install, enable and start using your new shortcodes.

Features

  • Lightweight and fast
  • Secure code with using clear coding standards
  • Intuitive interface with many settings
  • Cross browser compatible (work smooth in any modern browser)
  • Compatible with all WordPress themes
  • RTL compatible (right to left)
  • Translation ready

Key features include

  • Standalone Shortcode-Processor
  • Code syntax highlighting
  • Line numbering
  • Dollar sign before line
  • 36 Themes
  • 13 Programming languages
  • 15 Shortcodes
  • Allow shortcodes in the text widget
  • And much, much more!

PRO features include

  • 56 Themes (all provided themes from CodeMirror)
  • 154 Programming languages (all provided languages from CodeMirror)
  • 125 Shortcodes
  • Programming language selection option
  • Loading CodeMirror files on pages only when needed
  • Line wrapping
  • No ads on the settings page
  • Well documented

A list of supported languages

Click to view language examples. Highlighted with Default theme.

A list of supported shortcodes

  • [code][/code] - customizable shortcode
  • [apl][/apl]
  • [asciiarmor][/asciiarmor]
  • [asn.1][/asn.1]
  • [asterisk][/asterisk]
  • [brainfuck][/brainfuck]
  • [clike][/clike]
  • [clojure][/clojure]
  • [cmake][/cmake]
  • [cobol][/cobol]
  • [coffeescript][/coffeescript]
  • [commonlisp][/commonlisp]
  • [crystal][/crystal]
  • [css][/css]
  • [cypher][/cypher]
  • [d][/d]
  • [dart][/dart]
  • [diff][/diff]
  • [django][/django]
  • [dockerfile][/dockerfile]
  • [dtd][/dtd]
  • [dylan][/dylan]
  • [ebnf][/ebnf]
  • [ecl][/ecl]
  • [eiffel][/eiffel]
  • [elm][/elm]
  • [erlang][/erlang]
  • [factor][/factor]
  • [fcl][/fcl]
  • [forth][/forth]
  • [fortran][/fortran]
  • [gas][/gas]
  • [gfm][/gfm]
  • [gherkin][/gherkin]
  • [go][/go]
  • [groovy][/groovy]
  • [haml][/haml]
  • [haskell][/haskell]
  • [haskell-literate][/haskell-literate]
  • [haxe][/haxe]
  • [html][/html]
  • [htmlembedded][/htmlembedded]
  • [htmlmixed][/htmlmixed]
  • [http][/http]
  • [idl][/idl]
  • [javascript][/javascript]
  • [jinja2][/jinja2]
  • [js][/js]
  • [jsx][/jsx]
  • [julia][/julia]
  • [less][/less]
  • [livescript][/livescript]
  • [lua][/lua]
  • [markdown][/markdown]
  • [mathematica][/mathematica]
  • [mbox][/mbox]
  • [mirc][/mirc]
  • [mllike][/mllike]
  • [modelica][/modelica]
  • [mscgen][/mscgen]
  • [mumps][/mumps]
  • [mysql][/mysql]
  • [nginx][/nginx]
  • [nsis][/nsis]
  • [ntriples][/ntriples]
  • [null][/null]
  • [octave][/octave]
  • [oz][/oz]
  • [pascal][/pascal]
  • [pegjs][/pegjs]
  • [perl][/perl]
  • [php][/php]
  • [pig][/pig]
  • [powershell][/powershell]
  • [properties][/properties]
  • [protobuf][/protobuf]
  • [pug][/pug]
  • [puppet][/puppet]
  • [python][/python]
  • [q][/q]
  • [r][/r]
  • [rpm][/rpm]
  • [rst][/rst]
  • [ruby][/ruby]
  • [rust][/rust]
  • [sas][/sas]
  • [sass][/sass]
  • [scheme][/scheme]
  • [scss][/scss]
  • [shell][/shell]
  • [sieve][/sieve]
  • [slim][/slim]
  • [smalltalk][/smalltalk]
  • [smarty][/smarty]
  • [solr][/solr]
  • [soy][/soy]
  • [sparql][/sparql]
  • [spreadsheet][/spreadsheet]
  • [sql][/sql]
  • [stex][/stex]
  • [stylus][/stylus]
  • [swift][/swift]
  • [tcl][/tcl]
  • [textile][/textile]
  • [tiddlywiki][/tiddlywiki]
  • [tiki][/tiki]
  • [toml][/toml]
  • [tornado][/tornado]
  • [troff][/troff]
  • [ttcn][/ttcn]
  • [ttcn-cfg][/ttcn-cfg]
  • [turtle][/turtle]
  • [twig][/twig]
  • [vb][/vb]
  • [vbscript][/vbscript]
  • [velocity][/velocity]
  • [verilog][/verilog]
  • [vhdl][/vhdl]
  • [vue][/vue]
  • [webidl][/webidl]
  • [xml][/xml]
  • [xquery][/xquery]
  • [yacas][/yacas]
  • [yaml][/yaml]
  • [z80][/z80]

A list of supported themes

  • 3024 day
  • 3024 night
  • ABCDEF
  • Ambiance
  • Ambiance mobile
  • Base16 dark
  • Base16 light
  • Bespin
  • Blackboard
  • Cobalt
  • Colorforth
  • Darcula
  • Dracula
  • Duotone dark
  • Duotone light
  • Eclipse
  • Elegant
  • Erlang dark
  • Gruvbox dark
  • Hopscotch
  • Icecoder
  • Idea
  • Isotope
  • Lesser dark
  • Liquibyte
  • Lucario
  • MBO
  • MDN-like
  • Material
  • Midnight
  • Monokai
  • Neat
  • Neo
  • Night
  • Oceanic next
  • Panda syntax
  • Paraiso dark
  • Paraiso light
  • Pastel on dark
  • Railscasts
  • Rubyblue
  • SSMS
  • Seti
  • Shadowfox
  • Solarized
  • TTCN
  • The matrix
  • Tomorrow night bright
  • Tomorrow night eighties
  • Twilight
  • Vibrant ink
  • XQ dark
  • XQ light
  • Yeti
  • Zenburn

Translation

This plugin is ready for translation and has already been translated into several languages. But If your language is not available then you can make one. It is also possible that not all existing translations are up to date, so you are welcome to make corrections. Many of plugin users would be delighted if you share your translation with the community. Thanks for your contribution!

  • English (default)
  • Russian (translation by Milena Kiseleva)
  • German (translation by Michael)
  • Spanish (translation by Ramiro Garcés and Patricio Toledo)
  • Dutch (translation by Peter Leenders)

If you want to help translate this plugin, please use the POT file that is included and placed in the languages folder to create a translation PO file. Just send the PO file to us and we will include this translation within the next plugin update.

Minimum system requirements

  • PHP version 5.3 or higher.
  • MySQL version 5.0 or higher.
  • PHP version 7.0 or higher.
  • MySQL version 5.6 or higher.